A security release 3.1 of plugin Google Maps is released (block features that are vulnerable) and this must be applied to your Joomla installation.
The proxy feature is secured and restored in version 3.2 (see article).

The files can be downloaded here.

In previous version before 3.1, the proxy solution (plugin_googlemap2_proxy.php and plugin_googlemap3_proxy.php) for kml files has the following vulnerabilities: Denial of Service, XML Injection, Cross-Site Scripting and Full path disclosure vulnerabilities In this version 3.1 the proxy solution is not possible anymore.
For solutions on the attack see this article on the internet.

I am sorry for the trouble I may have caused.

I hope you can have fun again with the plugin.