Joomla plugin Google Maps version 2.19 and lower is deprecated. Please upgrade to version 3.1 of the plugin. 

This is obsolete now, because Google will deprecate JavaScript Maps API v2 on November 19, 2013 and also the geocoding service is already down since 12th September.
If you use an address in this version, you will get php errors on your website.

The Plugin version 3.1 uses Google javascript Maps API v3 and the related Geocoding service.

Have fun with the plugin.